Delays in Updating GitHub Statuses for Check Workflows
Incident Report for Apollo Graph, Inc.
Resolved
This incident has been resolved.
Posted Aug 29, 2022 - 11:24 PDT
Update
We're seeing regular delay for updating Schema Checks through to GitHub statuses.

As always, we appreciate your patience. If you're seeing continued lag, we encourage you to open a support ticket!
Posted Aug 29, 2022 - 11:24 PDT
Update
Our DB CPU is now back to a regular operational level and we are working through our backlog of messages. We are going to start scaling up our fleet and observe the impact to our queues.

We will update in 20 minutes.
Posted Aug 29, 2022 - 11:00 PDT
Monitoring
We have implemented the new index in our production environment and are awaiting statistics to confirm its impact. The overall end customer impact here appears to be rather small with our message backlog actually being held off in this degraded state quite well.

We will update again in 20 minutes once we have adequate metrics.
Posted Aug 29, 2022 - 09:59 PDT
Identified
We have identified an errant database query and are working to implement a fix, most likely by adding another index, which should alleviate pressure on our database and allow us to scale up our full fleet of services devoted to updating GitHub statuses.

We are still processing GitHub status updates, though we are still seeing some delay.

We will update again in 20 minutes.
Posted Aug 29, 2022 - 09:35 PDT
Investigating
We are currently seeing an increased latency in updating statuses for Apollo Studio Workflows. We are actively working on this issue, and will update again herein 15 minutes as we know more.

As always, we appreciate your patience.
Posted Aug 29, 2022 - 08:38 PDT
This incident affected: Schema Checks.