The issue has been resolved.
Resolved
Monitoring
The issue has been resolved and we're continuing to monitor.
Investigating
Registry service workflow latency has spiked, affecting mulitple internal services serving long-running workflows.