Resolved
This incident has been resolved.
Monitoring
Loading times for insights and metrics are still elevated. We are going to take additional actions to improve performance over the next few hours.
Monitoring
Our systems have returned to a normal state. We'll continue to monitor and share updates within the next hour.
Investigating
We are continuing to investigate this issue.
Investigating
We are currently investigating an issue with loading metrics in Studio.