Resolved
The issue has been resolved.
Monitoring
We've implemented a fix and are monitoring the system.
Investigating
We're continuing to investigate the root cause of the issue. Some customers are reporting significant improvements in performance.
Investigating
We're still investigating the root cause. We're seeing some recovery, but not to full recovery
Investigating
Platform API is also seeing degraded performance, which we are investigating
Investigating
We're seeing increases in latency across a few different Apollo services. You may be seeing latency issues with proposals, checks, and studio.