Studio Single Sign-On (SSO) login failures
Incident Report for Apollo Graph, Inc.
Resolved
We believe the incident preventing users from logging in with their SSO providers (like Okta or PingOne) to be resolved. Again, no CLI or API access usage using graph tokens was impacted during this time, only login workflows through the Studio web interface.

We don't believe it is necessary but — as this was a login problem — if you continue to experience troubles logging in, please try using your browser's private browsing mode. If the issues persist, contact our support team.

We will be taking measures on our end to reduce the potential of this happening in the future and we appreciate your patience during the outage.
Posted Aug 26, 2022 - 14:59 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 26, 2022 - 14:40 UTC
Monitoring
Thanks to a fix implemented with our upstream identity provider, our SSO login is working again as of about 20 minutes ago. We will continue to monitor the situation.
Posted Aug 26, 2022 - 14:40 UTC
Identified
Our identity provider has identified the reason why their systems are refusing our attempts to negotiate SSO logins for our users.

We are working with their teams to find a resolution. We apologize for the inconvenience and appreciate your patience.
Posted Aug 26, 2022 - 14:04 UTC
Update
Our users continue to experience errors when attempting to log in with SSO. We have verified that Studio Graph tokens and CLI usage for tokens which have already been created continue to work.

We are in communication with our identity provider and we will provide more updates as soon as they are available.
Posted Aug 26, 2022 - 12:20 UTC
Investigating
We are currently investigating reports of problems logging in with SSO providers (e.g., Okta, PingOne, etc.). Logins with GitHub and email/password combinations are working correctly and this only affects SSO logins.
Posted Aug 26, 2022 - 09:35 UTC
This incident affected: Studio UI.