Studio UI & schema checks degraded for graphs that have recently migrated to Federation 2
Incident Report for Apollo Graph, Inc.
Resolved
This incident has been resolved.
Posted Apr 14, 2022 - 03:31 PDT
Monitoring
We have identified the root cause of the issue as a bug in how Studio was performing additional validations around deprecations within a supergraph schema. We have rolled back the errant validations and are continuing to monitor for any further breakages. We believe all Studio UI issues to be resolved at this time, though users will need to manually re-run checks that failed to complete.
Posted Apr 14, 2022 - 03:21 PDT
Investigating
We are aware of an issue that is causing graph variants that have recently migrated to Federation 2 to encounter long-running schema checks stuck in the "PENDING" status as well as inability to load schemas that were previously registered with Federation 1. We believe this is currently only affecting graph variants that migrated prior to 5pm Pacific today under special circumstances.

As we further identify those affected, we will report back. Uplink and schema publishing of valid Federation 2 schemas should not be affected.
Posted Apr 14, 2022 - 02:42 PDT
This incident affected: Schema Checks and Studio UI.