We have received confirmation from our upstream vendor that they have identified the errant code on their end, and have seen their alerts resolve.
We will be closing this at this time, please feel free to reach out to support, or to Apollo on our open source GH Issues.
Thanks as always for your patience!
Posted Aug 08, 2025 - 11:35 UTC
Monitoring
We are seeing recovery and our alerts have returned to normal. We did see that this originally started at 2025-08-08 04:27 UTC, and we will need to backdate it.
Posted Aug 08, 2025 - 11:21 UTC
Identified
We have identified that GitHub's CDN is returning 404s or stale data for Apollo release artifacts. We rely on the GitHub CDN for serving our release artifacts for tools which are distributed on GitHub, including Rover, the Apollo MCP Server and Router.
At this time, GitHub does not have a public status page that shows this, but there are many reports of it on the GitHub Community forums and there is correspondence on other projects (such as the Aqua project, seen here: https://github.com/aquaproj/aqua/issues/4068#issuecomment-3166806915).