Sporadic 502s when checking a schema
Incident Report for Apollo Graph, Inc.
Resolved
We have not seen a repeat of the 502s and appear to be stable. We will continue to monitor a handful of clients as canaries, and continue to rollout our high priority changes to allow for more load.

As always, thank you for your patience!
Posted Sep 07, 2021 - 21:52 UTC
Monitoring
We are now monitoring our changes as we have only seen 1 instance of a 502 in the last hour. We will leave this incident in monitoring till all of our changes have rolled out.
Posted Sep 07, 2021 - 21:04 UTC
Update
We are continuing to see a very high rate of success for most clients. We are rolling a number of changes for our largest customers to try and alleviate these sporadic 502 issues.
Posted Sep 07, 2021 - 20:23 UTC
Identified
We are seeing sporadic 502 errors when checking a schema. We believe this is because timeouts are getting exceeded so are working on bumping the relevant timeouts where possible to mitigate this error.

This error does not look like it is effecting other parts of our API or publishes.
Posted Sep 07, 2021 - 19:01 UTC
This incident affected: GraphQL API.