Installing, Downloading Rover and plugins degraded

Incident Report for Apollo Graph, Inc.

Resolved

The downstream incident appears to be resolved. Thank you for your patience in this matter.
Posted 2 years ago. Jun 21, 2023 - 21:13 UTC

Identified

We have identified the issue as being related to a downstream provider's outage. We will update this post with information as it becomes available.
Posted 2 years ago. Jun 21, 2023 - 19:57 UTC

Update

We are continuing to investigate this issue.
Posted 2 years ago. Jun 21, 2023 - 18:45 UTC

Investigating

We are currently investigating this issue.
Posted 2 years ago. Jun 21, 2023 - 18:44 UTC
This incident affected: Rover CDN.