Incomplete metrics for users of Apollo Server v2.24
Incident Report for Apollo Graph, Inc.
Resolved
This incident has been resolved.
Posted May 11, 2021 - 15:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2021 - 14:56 UTC
Update
We have released a fix for this issue and we are seeing new reports made succeeding to be ingested. We will continue to monitor for regressions and keep this page open as we continue to observe a normal success rate. Thank you for your patience.
Posted May 11, 2021 - 14:56 UTC
Identified
Our servers are discarding some statistics from servers running Apollo Server 2.24. For graphs in free orgs, this ends up discarding most of the statistics. This only affects users of Apollo Server 2.24. The issue is in Studio's servers and we will fix it shortly; no user change is needed.
Posted May 11, 2021 - 14:26 UTC
This incident affected: Metrics Ingestion.