Users unable to use @specifiedBy in managed federation 1.0 graphs
Incident Report for Apollo Graph, Inc.
Resolved
This issue has been resolved.
Posted May 23, 2022 - 22:32 UTC
Monitoring
Users using federation 1.0 composition and `@specifiedBy` directives would get an error saying `Unknown directive "@specifiedBy".`.

This was due to a misconfiguration in federation 1.0 validation logic which used graphql-js 15.0.0 to validate the generated supergraph core schema rather than using graphql-js 15.7.2.

This bug was introduced at 18:20 UTC May 23, and a fix was released at 08:53 UTC May 24.
Posted May 23, 2022 - 22:32 UTC
This incident affected: Schema Publishing.