Degredaded performance across several Apollo GraphOS services

Incident Report for Apollo Graph, Inc.

Resolved

The issue has been resolved.
Posted Nov 21, 2025 - 21:25 UTC

Monitoring

We've implemented a fix and are monitoring the system.
Posted Nov 21, 2025 - 20:44 UTC

Update

We're continuing to investigate the root cause of the issue. Some customers are reporting significant improvements in performance.
Posted Nov 21, 2025 - 19:55 UTC

Update

We're still investigating the root cause. We're seeing some recovery, but not to full recovery
Posted Nov 21, 2025 - 19:01 UTC

Update

Platform API is also seeing degraded performance, which we are investigating
Posted Nov 21, 2025 - 17:56 UTC

Investigating

We're seeing increases in latency across a few different Apollo services. You may be seeing latency issues with proposals, checks, and studio.
Posted Nov 21, 2025 - 17:51 UTC
This incident affected: Schema Checks, Studio UI, and Schema Proposals.