Lint Checks failing to report Composition Hints
Incident Report for Apollo Graph, Inc.
Resolved
Rollback has successfully fixed the issue. We will be conducting a postmortem this week. We appreciate your patience.
Posted Jan 15, 2024 - 02:03 UTC
Identified
We deployed code that caused Composition Hints to not be reported in Lint Check tasks. Composition hints and errors were accurately reported for publishes and Build tasks in checks.

Users with checks configured to fail on Lint Composition Hints will have seen checks pass incorrectly.
Posted Jan 15, 2024 - 02:03 UTC
Investigating
We deployed code that caused Composition Hints to not be reported in Lint Check tasks. Composition hints and errors were accurately reported for publishes and Build tasks in checks.

Users with checks configured to fail on Lint Composition Hints will have seen checks pass incorrectly.
Posted Jan 12, 2024 - 11:00 UTC
This incident affected: Schema Checks.