GCS Schema Delivery Partial Outage
Incident Report for Apollo Graph, Inc.
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 18:52 UTC
Investigating
Between February 16th, at 21:24 UTC and February 22nd at 18:52 UTC, Apollo had a bug in our GCS Schema Delivery Pipeline.

To be impacted by this bug, customers would need to:

- Be on an Apollo Gateway version before 0.45.0, and have their Gateway set to receive SuperGraph configuration via GCS
- NOTE: In Apollo Gateway version 0.34.0 we changed SuperGraph delivery to default to Uplink
- Be on Federation version 1.0
- Make a change to a Subgraph URL but NOT make a change to their Subgraph's schema

If you believe you fall into the above camp, you will be able to resolve this issue on your end by making any deployment whatsoever to the variant in question.

Please reach out to support for any further questions.
Posted Feb 16, 2023 - 21:24 UTC
This incident affected: Uplink.