Elevated Errors for Users Using Legacy Tokens
Incident Report for Apollo Graph, Inc.
Resolved
Hoping this is the last of these for the day. As always, thanks for the patience folks
Posted May 03, 2021 - 22:21 UTC
Monitoring
A fix has been deployed and we are monitoring. We will close this in 15 minutes if things look good.
Posted May 03, 2021 - 22:05 UTC
Identified
We've found the regression and are rolling out a fix internally to verify this will solve things. We will take this live afterwards. Please expect an update in 15 minutes.
Posted May 03, 2021 - 21:56 UTC
Investigating
We have identified a longer running permissions regression which removed appropriate access to Legacy tokens for at least the following resolvers:

- schemaTag
- schemaTags
- schema
- schemaById

NOTE: This could have impacted your usage of the Apollo Client and things like Codegen.
Posted May 03, 2021 - 20:35 UTC
This incident affected: GraphQL API.