Users unable to override schema check configuration when calling API directly
Incident Report for Apollo Graph, Inc.
Resolved
This incident has been resolved.
Posted May 19, 2022 - 21:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2022 - 20:07 UTC
Update
We are in the process of rolling out a fix to allow numeric overrides.
Posted May 19, 2022 - 19:40 UTC
Identified
We are in the midst of validating a fix that we believe will resume accepting numeric input for `from` and `to` overrides for direct API callers.
Posted May 19, 2022 - 17:09 UTC
Investigating
We are currently in the midst of resolving an issue around input coercion for users of schema checks that are calling our API directly or using the (legacy) Apollo Language Server to perform schema checks. If you are affected, you may receive errors indicating that your `historicParameters.from` and `historicParameters.to` could not be parsed.

To resolve, please wrap these values in quotation marks `"`. We are in the midst of fixing the issue to accept numeric input via the API and will update his page as we make progress.
Posted May 19, 2022 - 16:34 UTC
This incident affected: Schema Checks.