Use of "rover dev" on Linux impacted by GitHub "Unauthorized" error
Incident Report for Apollo Graph, Inc.
Resolved
We are confident that things are working correctly and marking this incident as resolved.
Posted Nov 22, 2023 - 12:21 UTC
Monitoring
We have mitigated the impact on Linux users of "rover dev" by changing the way that we follow redirects to GitHub. This compensates for a change that manifested in the way GitHub serves assets from their CDN which resulted in HEAD requests returning 401 where the GET requests worked properly. This mitgation should be transparent for all users.

We have confirmed that "rover dev" for Linux is working again and we will monitor the continued necessity of the mitigation. We appreciate your patience during the investigation.
Posted Nov 22, 2023 - 12:03 UTC
Investigating
We are currently investigating an upstream unavailability of the Linux Router binary which is downloaded and invoked by the "rover dev" CLI command in Rover. Other architectures (like macOS) do not seem to be impacted. We are investigating the cause.
Posted Nov 22, 2023 - 09:52 UTC
This incident affected: Rover CDN.